TimeTechTalk.com Home

TimeTechTalk.com > 3T Official Brand Forums > Dievas Uhren Technik > Aqua Luna bracelet installation problem Help!

Welcome to 3T! Please take the time to register and join in on the friendly,knowledgeable watch talk.Please note that not all registrations will receive an immediate activation e-mail.Those who do not receive an immediate notification will be activated manually within 48hrs. by an admin. without an e-mail activation url sent to you,you may then sign in using your username and password,if you feel there is a problem please e-mail us at timetechtalk@hotmail.com and include your name and username and we activate your account.Thank You!

 Moderated by: 3T
New Topic Reply Printer Friendly
Aqua Luna bracelet installation problem Help!  Rate Topic 
AuthorPost
 Posted: Thu Mar 25th, 2010 04:56 pm
  PM Quote Reply
1st Post
nanoman
3T WIS


Joined: Sun Jan 3rd, 2010
Location: Oak Creek, Wisconsin USA
Posts: 134
Status: 
Offline
I have installed 100+ bracelets without difficulty. The  bracelet Anders sent me just will not go on my AquaLuna with many attempts. I really need some hints and tricks you AquaLuna owners might have so I can succeed.

I do have all of the cool Bergeon tools just can't get both pins to connect.

Thanks

Back To Top PM Quote Reply  

 Posted: Fri Mar 26th, 2010 01:57 am
  PM Quote Reply
2nd Post
bigrustypig
3T WIS


Joined: Sat Apr 11th, 2009
Location: Auckland, New Zealand
Posts: 7506
Status: 
Offline
nanoman wrote: I have installed 100+ bracelets without difficulty. The  bracelet Anders sent me just will not go on my AquaLuna with many attempts. I really need some hints and tricks you AquaLuna owners might have so I can succeed.

I do have all of the cool Bergeon tools just can't get both pins to connect.

Thanks


Nanoman, I never had problems with my 2 ALs. Maybe one trick, if you have some spare pins, is to try out a brand new one. Another one is to use one half of the other on the other.

Hope this helps.sponge bob.gif

 

Back To Top PM Quote Reply

 Posted: Fri Mar 26th, 2010 02:41 am
  PM Quote Reply
3rd Post
Nabco
3T WIS


Joined: Sat Dec 2nd, 2006
Location: Ohio, N. Carolina & Delta Seat 1C
Posts: 3838
Status: 
Offline
I've swapped mine out a couple times with no issues...you should probably email or PM Anders to see if he can help.

Back To Top PM Quote Reply  

 Posted: Fri Mar 26th, 2010 03:44 am
  PM Quote Reply
4th Post
nanoman
3T WIS


Joined: Sun Jan 3rd, 2010
Location: Oak Creek, Wisconsin USA
Posts: 134
Status: 
Offline
It seems that the issue is keeping the spring bar sqeezed together  on both sides at the same time. But I would have to have a horotec spring bar tweezers or a Bergeon watch band pliers. The tweezers does not seem as good as the Bergeon model 6618 for about $42 verses the $33 for the tweezer. Has anyone used either?

Thanks

I did speak to Anders and he told me how but that is difficult without practice and I do not want to practice on this level of watch. I don't have this problem with other watches. I bought the watch without the bracelet and probably due to new installation and no fine tuning when installed from factory. Not broken it I guess

Back To Top PM Quote Reply

Current time is 10:10 am  
TimeTechTalk.com > 3T Official Brand Forums > Dievas Uhren Technik > Aqua Luna bracelet installation problem Help! Top



Lead Theme By: Di @ UltraBB
UltraBB 1.17 Copyright © 2007-2012 Data 1 Systems
Page processed in 0.1467 seconds (14% database + 86% PHP). 28 queries executed.